anything related to UI in general, splash screens, UI widgets, input and output etc.

Help please

Help please

Postby epsilonion » 04 Aug 2015, 23:20

I had this working then crash and its never worked since lol...

Basically in the zip file is a scene, script and GUI.

what its supposed to do is when you walk into the trigger box in front of the lorry it hides the HUD and displays a tutorial picture, then if you click on the picture or on the exit button its supposed to show the hud , hide the tutorial picture and continue the game.

its working apart from when you click the picture or exit button it displays entity -1 error, I dont know if it is because I called globalfn() (tried the callfn() but it didnt want to work) in the HUD micro script to get the HUD to hide and its messed up the object ID ir what but its gotten me stumpped spent days and days on this one and I finally give up lol..

http://eve-lbs.co.uk/downloads/help.zip
User avatar
epsilonion
Skyline Lead Moderator
Skyline Lead Moderator
 
Posts: 866
Joined: 26 Feb 2015, 11:51
Location: Hull, East Yorkshire, England
Skill: Business Manager
Skill: Great creative

Re: Help please

Postby StarFire » 05 Aug 2015, 15:55

Just having a look at the file you sent.

On a side note did you know that the trigger volume has a debug option that keeps the transparent material showing in play mode. This makes it easier to see when testing ;)
Dream the Journey, Live the Experience!
User avatar
StarFire
Skyline Founder
Skyline Founder
 
Posts: 1455
Joined: 03 Jan 2012, 18:50
Location: UK
Skill: Great creative
Skill: Programmer
Skill: 3D Modeller
Skill: 2D Artist
Skill: Level Designer

Re: Help please

Postby StarFire » 05 Aug 2015, 16:38

Ok I have found your fault. In the fpstut.rml you have used the script name in the lua(....) command not the object tag name of the entity with the script!

Code: Select all
use:
lua(15,tutorialButtonEvent,1)"
not:
lua(TriggertutorialDiag2,tutorialButtonEvent,1)"


This seems to work as expected ;)

Note its best not to use just a numerical tag so that this does not get confused with object ID, so in this case, name the tag of the volume to say volume_15 and add that to the rml files lua command.
Dream the Journey, Live the Experience!
User avatar
StarFire
Skyline Founder
Skyline Founder
 
Posts: 1455
Joined: 03 Jan 2012, 18:50
Location: UK
Skill: Great creative
Skill: Programmer
Skill: 3D Modeller
Skill: 2D Artist
Skill: Level Designer

Re: Help please

Postby epsilonion » 05 Aug 2015, 21:01

Your a star.... that was doing my head in... lol

Now thats working the pause menu in the scene script has stopped working now.. lol... oh my... lol
User avatar
epsilonion
Skyline Lead Moderator
Skyline Lead Moderator
 
Posts: 866
Joined: 26 Feb 2015, 11:51
Location: Hull, East Yorkshire, England
Skill: Business Manager
Skill: Great creative

Re: Help please

Postby StarFire » 05 Aug 2015, 21:02

lol :shock: :lol:

you will get there its generally something simple and easy overlooked ;)

Im here if you need help :D
Dream the Journey, Live the Experience!
User avatar
StarFire
Skyline Founder
Skyline Founder
 
Posts: 1455
Joined: 03 Jan 2012, 18:50
Location: UK
Skill: Great creative
Skill: Programmer
Skill: 3D Modeller
Skill: 2D Artist
Skill: Level Designer


Return to UI

Who is online

Users browsing this forum: No registered users and 1 guest

cron