Post anything here that does not fall into the other topic categories.

custom .OGG/.WAV audio not working

custom .OGG/.WAV audio not working

Postby lordalmighty1 » 27 Jan 2015, 13:44

o I am playing around now with the audio features, have tested many of the default audio media that came with skyline works great..
custom audio does not however work for me, im probably missing something but everytime I goto put a .ogg or .wav file in for testing it comes back with an error like so :Failed to create sound thunderstorm.OGG - Could be an audio format error common with some wav file formats: not sure what to make of it unless its an issue with capitals?. or something else perhaps??.

any help would be appreciated :) thanks
User avatar
lordalmighty1
Skyline Moderator
Skyline Moderator
 
Posts: 442
Joined: 02 Jan 2014, 12:13
Location: uk
Skill: Great creative
Skill: Level Designer

Re: custom .OGG/.WAV audio not working

Postby SolarPortal » 27 Jan 2015, 13:53

i think this is a resource error.

open the asset manager and locate the folder the sound is stored in.
right click on the folder in the explorer view and on the RMB context menu, choose "Resource Management" -> "Add to resource list". This will make the audio available to skyline in order to be used.

The sound does not require a path in order to work as it is pulled from the resource list. :)

The audio actions could be improved to make the resource addition easier like models and textures etc...
User avatar
SolarPortal
Skyline Founder
Skyline Founder
 
Posts: 3121
Joined: 29 Jul 2012, 15:56
Location: UK
Skill: 3D Modeller
Skill: 2D Artist
Skill: Programmer
Skill: Level Designer

Re: custom .OGG/.WAV audio not working

Postby lordalmighty1 » 27 Jan 2015, 21:16

ERROR: Failed to create sound Thunderstorm101.WAV - Could be an audio format error common with some wav file formats

I still get the above problem, after doing your fix :(
User avatar
lordalmighty1
Skyline Moderator
Skyline Moderator
 
Posts: 442
Joined: 02 Jan 2014, 12:13
Location: uk
Skill: Great creative
Skill: Level Designer

Re: custom .OGG/.WAV audio not working

Postby SolarPortal » 27 Jan 2015, 21:23

is it a 24bit or 16bit wav?
Skyline only handles "16bit" at "44.1 khz" for a wav file.

Skyline prefers to work with ogg files, they are more reliable when loading and more memory efficient as WAV files are too big for games.

Here is a link to an online converter: http://audio.online-convert.com/convert-to-ogg

then try the procedure again. :)
User avatar
SolarPortal
Skyline Founder
Skyline Founder
 
Posts: 3121
Joined: 29 Jul 2012, 15:56
Location: UK
Skill: 3D Modeller
Skill: 2D Artist
Skill: Programmer
Skill: Level Designer

Re: custom .OGG/.WAV audio not working

Postby lordalmighty1 » 27 Jan 2015, 21:28

right will do thanks for rapid reply :)
User avatar
lordalmighty1
Skyline Moderator
Skyline Moderator
 
Posts: 442
Joined: 02 Jan 2014, 12:13
Location: uk
Skill: Great creative
Skill: Level Designer

Re: custom .OGG/.WAV audio not working

Postby SolarPortal » 27 Jan 2015, 21:28

np :)
User avatar
SolarPortal
Skyline Founder
Skyline Founder
 
Posts: 3121
Joined: 29 Jul 2012, 15:56
Location: UK
Skill: 3D Modeller
Skill: 2D Artist
Skill: Programmer
Skill: Level Designer

Re: custom .OGG/.WAV audio not working

Postby TattieBoJangle » 27 Jan 2015, 21:47

Guys i also have a problem with the audio not custom just changing it causes it to stop working

User avatar
TattieBoJangle
Skyline Contributor
Skyline Contributor
 
Posts: 843
Joined: 26 Jan 2015, 00:15
Location: United Kingdom
Skill: 3D Modeller
Skill: 2D Artist
Skill: Level Designer
Skill: Great creative

Re: custom .OGG/.WAV audio not working

Postby SolarPortal » 27 Jan 2015, 21:53

just had a play, and it seems if there is a sound that does not work; the volume is set to 0, but leaves the slider at 1.
when reset to the working sound, move the volume slider a tiny bit to kick the audio back in.

This is a bug :)
User avatar
SolarPortal
Skyline Founder
Skyline Founder
 
Posts: 3121
Joined: 29 Jul 2012, 15:56
Location: UK
Skill: 3D Modeller
Skill: 2D Artist
Skill: Programmer
Skill: Level Designer

Re: custom .OGG/.WAV audio not working

Postby TattieBoJangle » 27 Jan 2015, 21:57

Thanks that fixes it.
User avatar
TattieBoJangle
Skyline Contributor
Skyline Contributor
 
Posts: 843
Joined: 26 Jan 2015, 00:15
Location: United Kingdom
Skill: 3D Modeller
Skill: 2D Artist
Skill: Level Designer
Skill: Great creative

Re: custom .OGG/.WAV audio not working

Postby lordalmighty1 » 27 Jan 2015, 22:39

ok the issue for me maywell be a "drm" encryption issue with the software I use for sounds :(
according to the link converter anyways it wont convert to ogg for that reason so im guessing that's the cause for skyline also??.
pity really I got that software to make audio for games and appears not to like doing it lol.. live and learn I guess haha..
thanks for the help and info :)
User avatar
lordalmighty1
Skyline Moderator
Skyline Moderator
 
Posts: 442
Joined: 02 Jan 2014, 12:13
Location: uk
Skill: Great creative
Skill: Level Designer

Re: custom .OGG/.WAV audio not working

Postby SolarPortal » 27 Jan 2015, 22:53

oh, what software is it that you use?

we haven't encountered this issue before, so we couldn't really say if this was the problem or not.
if you need any more help though, we are here.... well about to turn off for the night now lol :P but we will respond tomorrow :)
User avatar
SolarPortal
Skyline Founder
Skyline Founder
 
Posts: 3121
Joined: 29 Jul 2012, 15:56
Location: UK
Skill: 3D Modeller
Skill: 2D Artist
Skill: Programmer
Skill: Level Designer

Re: custom .OGG/.WAV audio not working

Postby lordalmighty1 » 27 Jan 2015, 23:35

magic music maker 2014 basic edition.
User avatar
lordalmighty1
Skyline Moderator
Skyline Moderator
 
Posts: 442
Joined: 02 Jan 2014, 12:13
Location: uk
Skill: Great creative
Skill: Level Designer

Re: custom .OGG/.WAV audio not working

Postby SolarPortal » 28 Jan 2015, 10:43

not seen or used that one before. We use an old copy of sound forge 9.

Edit: StarFire has used that, and does not recommend it at all. few choice words lol :P
User avatar
SolarPortal
Skyline Founder
Skyline Founder
 
Posts: 3121
Joined: 29 Jul 2012, 15:56
Location: UK
Skill: 3D Modeller
Skill: 2D Artist
Skill: Programmer
Skill: Level Designer

Re: custom .OGG/.WAV audio not working

Postby lordalmighty1 » 28 Jan 2015, 11:07

hahaha I got it a bout a year or so ago when it first came out I don't really use it for anything so limited and such..
but I thought it might be ok for the atmos and syth labs it has guess I was wrong lol..
User avatar
lordalmighty1
Skyline Moderator
Skyline Moderator
 
Posts: 442
Joined: 02 Jan 2014, 12:13
Location: uk
Skill: Great creative
Skill: Level Designer

Re: custom .OGG/.WAV audio not working

Postby StarFire » 28 Jan 2015, 12:42

Oh magix not the best for pro audio processing but I have used their samples in various music productions. They seem to like an in house approach to formats so never relied on them for this.
User avatar
StarFire
Skyline Founder
Skyline Founder
 
Posts: 1420
Joined: 03 Jan 2012, 18:50
Location: UK
Skill: Great creative
Skill: Programmer
Skill: 3D Modeller
Skill: 2D Artist
Skill: Level Designer

Re: custom .OGG/.WAV audio not working

Postby lordalmighty1 » 28 Jan 2015, 14:39

right ok :)
User avatar
lordalmighty1
Skyline Moderator
Skyline Moderator
 
Posts: 442
Joined: 02 Jan 2014, 12:13
Location: uk
Skill: Great creative
Skill: Level Designer

Re: custom .OGG/.WAV audio not working

Postby FantaSanta » 29 Jan 2019, 12:39

I think this click here can help you
User avatar
FantaSanta
Skyline Novice
 
Posts: 3
Joined: 29 Jan 2019, 12:16
Skill: 3D Modeller
Skill: Animator
Skill: Level Designer
Skill: Animator
Skill: Programmer


Return to Misc

Who is online

Users browsing this forum: No registered users and 1 guest

cron